[Snort-users] problem with snort/mysql

Sandra Rosada sandra.rosada at ...3884...
Mon Oct 22 08:40:08 EDT 2001


I've installed snort and mysql.
I've given this command
./snort -dev -l ./log -c snort.conf

I've had this error message:
-----------------------------

No arguments to frag2 directive, setting defaults to:

    Fragment timeout: 60 seconds
    Fragment memory cap: 4194304 bytes

Stream4 config:
    Stateful inspection: ACTIVE
    Session statistics:
INACTIVE
  
  Session timeout: 30 seconds
    Session memory cap: 8388608 bytes

State alerts: 
INACTIVE
    Scan alerts: ACTIVE
No arguments to stream4_reassemble,
setting defaults:
 
    Reassemble client: ACTIVE
     Reassemble server: INACTIVE
     
Reassemble ports: 21 23 25 53 80 143 110 111 513
     
Reassembly alerts: ACTIVE
database: mysql support is not compiled in this
copy

 
Check your configuration file to be sure you did not mis-spell "mysql".
 
If you did not, you will need to reconfigure and recompile ensuring that
 
you have set the correct options to the configure script. Type 
 
"./configure --help" to see options for the configure script.

Fatal Error, 
Quitting..
-------------------------------------


I've checked my snort.conf:
---------------------

output database: log, mysql, user=root dbname=snort host=monsley
output database: alert,mysql, user=root dbname=snort

-------------

I've recompiled :
-----------
./configure --with-mysql=/usr/local/mysql

----------

and the check in the output is
check for mysql ... yes
 
and then I run make and make install

but I've had the same error

Can someone suggest me any solution?
Thank you very much
regards 
Sandra





More information about the Snort-users mailing list