[Snort-users] Compile under Linux kernel 2.4.3

Thomas Whipp tkw at ...1885...
Fri Jun 15 09:55:47 EDT 2001


looks like you don't have all of the support libraries/tools
installed - pcap is generally built using a grammer parser
of which lex is one.  I'm not great on the details of this
but I suggest you fire up YaST and install any of the other
development tools called something like lex and then try
again.

Alternatively download the pcap source and look in the
readme file - it should tell you there.

cheers

	Tom

> -----Original Message-----
> From: Eric Van den Bossche [mailto:evdbossche at ...2292...]
> Sent: 15 June 2001 16:23
> To: snort-users at lists.sourceforge.net
> Subject: [Snort-users] Compile under Linux kernel 2.4.3
> 
> 
> I've compiled and installed without any problem Snort 1.7
under
> Linux Suse 7.0 with kernel 2.2.16.
> 
> But when I want to install it under Linux suse 7.1 with
kernel
> 2.4.3, I get the following error during the "make" :
> 
>
------------------------------------------------------------
--------
> /usr/local/lib/libpcap.a(gencode.o): In function
`pcap_compile':
> gencode.o(.text+0x255): undefined reference to `lex_init'
> /usr/local/lib/libpcap.a(grammar.o): In function
`yyparse':
> grammar.o(.text+0x95): undefined reference to `yylex'
> grammar.o(.text+0xa5b): undefined reference to `yylex'
> collect2: ld returned 1 exit status
> make: *** [snort] Error 1
>
------------------------------------------------------------
--------
> 
> I have already installed libpcap-0.4 and flex-2.5.4.
> 
> Do I still miss somethingelse ? 
> Any idea ?
> 
> Thanks.
> 
> Eric
> 
> 
> 
> 
> _______________________________________________
> Snort-users mailing list
> Snort-users at lists.sourceforge.net
> Go to this URL to change user options or unsubscribe:
> http://lists.sourceforge.net/lists/listinfo/snort-users
> Snort-users list archive:
> http://www.geocrawler.com/redir-sf.php3?list=snort-users
> 




More information about the Snort-users mailing list