[Snort-users] Snort 1.7 w/ MySQL not working

White, Michael D whitemd at ...1188...
Sun Jan 21 20:15:04 EST 2001


I am running Snort 1.7 with the database plugin.  Every time I try to
start snort (using 'snort -u snort -g snort -d -D -i eth0 -c
/etc/snort/snort.conf') I get the following error:
 
----- Start /var/log/messages -----
Jan 21 20:18:51 waters snort:  Check your configuration file to be sure
you did not mis-spell "mysql".  If you did not, you will need to
reconfigure and recompile ensuring that  you have set the correct
options to the configure script. Type   "./configure --help" to see
options for the configure script.  
----- Stop /var/log/messages -----
 
Here is how I have my snort.conf file layed out:
 
----- Start snort.conf -----
var HOME_NET xxx.xxx.xxx.xxx/xx
var EXTERNAL_NET any
preprocessor defrag
preprocessor http_decode: 80 8080
preprocessor portscan: $HOME_NET 4 3 /var/log/snort/portscan.log
output database: log, mysql, host=localhost dbname=snort user=XXX
password=XXX
 
<and then the rules....>
----- Stop snort.conf -----
 
I have tried both the RPMs and the source... both yield the same
results.  When I did a './configure' from the source tree, I made sure
that the 'mysql=yes' came up... I also tried to compile it with
'./configure --with-mysql=/usr'... nothing seems to work.
 
If anyone has any ideas our thoughts, they would be greatly appreciated!
 
Thanks,
Michael White


More information about the Snort-users mailing list