[Snort-users] problem with install

Scott Johnson scott at ...1124...
Thu Jan 11 14:06:22 EST 2001


Hopefully this will be an easy one, but I can't find any mention in the
archives.

I'm trying to install Snort on a new firewall system. When I use the
RPM, I get this error:

error: failed dependencies:
        libpcap >= 0.4 is needed by snort-1.7-1
        libcrypto.so.0 is needed by snort-1.7-1
        libssl.so.0 is needed by snort-1.7-1

Even though I already installed libpcap 0.4 from the gzip'ed source.

When I try to compile snort from source, I get this:

gcc -DHAVE_CONFIG_H -I. -I. -I. -I/usr/include/pcap 
-I/usr/local/ssl/include -DENABLE_SSL  -g -O2 -Wall  -c snort.c
In file included from snort.c:45:
snort.h:31: pcap.h: No such file or directory
snort.h:32: net/bpf.h: No such file or directory
In file included from snort.c:45:
snort.h:58: pcap-namedb.h: No such file or directory
In file included from snort.h:74,
                 from snort.c:45:
decode.h:30: pcap.h: No such file or directory
In file included from snort.h:74,
                 from snort.c:45:
decode.h:46: pcap-namedb.h: No such file or directory
make: *** [snort.o] Error 1

I've also installed openssl 0.9.6, both the engine and the libraries. 

This is a RH 6.1 install running the 2.2.18 kernel.

I know this is something I haven't installed or haven't installed
correctly, but I can't figure out what or why. Thanks in advance for any
help you can provide.




More information about the Snort-users mailing list