[Snort-users] compile cannot find libcap-04

Dragos Ruiu dr at ...381...
Tue Sep 19 05:12:49 EDT 2000


On Tue, 19 Sep 2000, Panji Wasmana wrote:
> Hello...
> 
> i trying to compile Snort-1.6.3, when ./configure step i found some
> error about libpcap (this cannot find libpcap library). But i allready
> install libpcap-04, it working properly.. because allready install
> TCPtrace.. that also need libpcap. so i trying to spesify using
> ./configure '--with-libpcap--includes=/usr/local/lib/libpcap.a' it
> ddoesnt work.. :(
> 
> i am using linux redhat 6.2
>

If you didn't install the libpacp rpm that came with the system
but instead installed it in /usr/local from a tarball
you'll have to point the install includes at /usr/local/include
the libraries at /usr/local/lib

try --with-libpcap-includes=  and --with-libpcap-libraries
note the singe dashes... (your example above is wrong)

With the default rpm libpcap it compiles without any complaints.
The current version of libpcap is .5 and is available at tcpdump.org

good luck,
--dr 

-- 
Dragos Ruiu <dr at ...50...>   dursec.com ltd. / kyx.net - we're from the future 
gpg/pgp key on file at wwwkeys.pgp.net



More information about the Snort-users mailing list