[Snort-users] Can't compile snort - no make targets

Don Heffernan donheff at ...88...
Wed Sep 13 13:00:38 EDT 2000


Thanks for the quick responses.  I quickly read up on what is going on when I
follow these steps and now understand that my configure is failing to genereate
a makefile.  I know also now have a very elementary idea of what the targets in
a makefile are.  I can't get a makefile out of this tarball so I will return
and see if I can find a slightly older version.

Thanks for all the 101 lessons and sorry for tying everyone up.

Fyodor wrote:

> ~ :> installing from tarballs is ./configure, make, and make install.  That
> ~ :> usually works but I ran into a problem at the make stage with
> ~ :> snort-1.6.3.  It returns the message: *** No targets. Stop.
> ~ :>
> ~ :> Any suggestions?
> ~ :
> ~ :Sounds like a funny make utility. :-)  have you tried using gmake?
> ~ :or another make clone?
> ~ :
>
> Well, another thing to check: are you sure that configure didn't fail to
> generate Makefile? `*** No targets. Stop' is what you usually get when
> Makefile is not presented and you don't give any targets to make to apply
> `generic' rules to build stuff.

--
Don Heffernan
heffernan.cais.net





More information about the Snort-users mailing list