[Snort-users] Snort & Flexresp & Libnet

Tye F. Hammerle thammer at ...445...
Mon Nov 27 22:02:45 EST 2000


Finally got around to playing with flexresp and I'm getting this error
making snort 1.7b5 on OpenBSD2.7 x86. I've installed libnet 1.0.1b. I
don't know enough yet to figure out how or where to fix this. Has
anyone else seen this or know what I can do to fix it?

I did ./configure --enable-flexresp then

# make
gcc  -g -O2 -Wall  -DENABLE_RESPONSE -DLIBNET_BSDISH_OS -DLIBNET_LIL_E
NDIAN -L/usr/lib -o snort  snort.o log.o decode.o mstring.o ru
les.o plugbase.o  sp_pattern_match.o sp_tcp_flag_check.o
sp_icmp_type_check.o  sp_icmp_code_check.o sp_ttl_check.o
sp_ip_id_check.o
sp_tcp_ack_check.o  sp_tcp_seq_check.o sp_dsize_check.o
spp_http_decode.o spp_minfrag.o  spp_portscan.o sp_ipoption_check.o
sp_rpc_c
heck.o sp_icmp_id_check.o  sp_icmp_seq_check.o sp_respond.o
spo_alert_syslog.o spo_log_tcpdump.o  spo_database.o sp_session.o
spp_de
frag.o parser.o spo_alert_fast.o  spo_alert_full.o spo_alert_smb.o
spo_alert_unixsock.o sp_react.o  spo_xml.o sp_ip_tos_check.o spp_
tcp_stream.o snprintf.o checksum.o
 sp_reference.o  -lpcap  -lssl -lcrypto -lnet
plugbase.c:58: Undefined symbol `_SetupRespond' referenced from text
segment
collect2: ld returned 1 exit status
*** Error code 1

Stop in /work/snort (line 216 of Makefile).
#


The middle line below is line 58 in plugbase.c.

#ifdef ENABLE_RESPONSE
    SetupRespond();
#endif



Tye




More information about the Snort-users mailing list