[Snort-users] RE: Lastest CVS Source

Frank Reid fcreid at ...691...
Fri Nov 10 08:41:27 EST 2000


> However, I can't seem to get past these:
>
>	/usr/include/openssl/rsa.h:262: parse error before `CRYPTO_EX_new'
>	In file included from /usr/include/openssl/dsa.h:80,
>                 from /usr/local/ssl/include/openssl/x509.h:81,
>                 from spo_xml.h:35,
>                 from plugbase.h:60,
>                 from snort.h:71,
>                 from snort.c:46:
>
> I suspect this is compiler-specific, given that it compiles under FreeBSD,
or it has something > to do with my installed version of openssl.  Any
thoughts?  Thanks.

Definitely something to do with openssl... by configuring --without-openssl,
I can get a clean compile (less the unrecognized operators in CONFIG.H I
described earlier).  I have openssl v0.9.5a developer's headers/libraries
installed... that's the same as what I have on the FreeBSD box that compiles
properly.

Where and how is openssl used within Snort?  Is it used for upstream
reporting from the sensor to a MySQL/PostgreSQL database?

Frank





More information about the Snort-users mailing list