[Snort-users] Lastest CVS Source

Frank Reid fcreid at ...691...
Fri Nov 10 07:48:04 EST 2000


Having some issues compiling the current source under RH7.  The configure
script seems to work properly.  However, the compiler doesn't want to handle
some of the "<<<<<<" and ">>>>>>" lines left in config.h, and it's now
choking on some of the included headers from openssl.  These apparently
weren't problems in the earlier CVS source (about a week or ten days ago),
and the compile under FreeBSD seems to work without issue.

Here's the error from config.h:

	In file included from snort.h:26,
                 from snort.c:46:
	config.h:18: parse error before `<'

I can get past this one by removing these lines:

	<<<<<<< config.h.in
	/* $Id: acconfig.h,v 1.2 2000/09/18 19:30:37 jpickel Exp $ */
	=======
	/* $Id: config.h.in,v 1.22 2000/11/08 23:06:38 roesch Exp $ */
	>>>>>>> 1.22

However, I can't seem to get past these:

	/usr/include/openssl/rsa.h:262: parse error before `CRYPTO_EX_new'
	In file included from /usr/include/openssl/dsa.h:80,
                 from /usr/local/ssl/include/openssl/x509.h:81,
                 from spo_xml.h:35,
                 from plugbase.h:60,
                 from snort.h:71,
                 from snort.c:46:

I suspect this is compiler-specific, given that it compiles under FreeBSD,
or it has something to do with my installed version of openssl.  Any
thoughts?  Thanks.

Frank





More information about the Snort-users mailing list