[Snort-users] Re: Problem running snort

Fyodor fygrave at ...121...
Thu Aug 17 05:34:11 EDT 2000


On Wed, 16 Aug 2000 out of nowhere Klaus Krtschil spoke:

~ :I have a problem when running snort (v1.6.3). The call is
~ :
~ : snort -c snort.rule -l some_directory
~ :
~ :I create the rules with the help of your webpage. It gives me an error
~ :message
~ :
~ :-----------
~ :Initializing Network Interface...
~ :ERROR: OpenPcap() device ppp0 open:
~ :        socket: Socket type not supported
~ :-----------
~ :
~ :I use a dial up connection (modem, 56K). Linux 2.2.14, no firewall.
~ :
~ :Can you give me a hint what is wrong/not installed/whatever ?
~ :

 You will need to enable SOCK_PACKET socket type in your kernel. If I am
not mistaking it is `Packet Socket' option in network options of your
kernel configuration.





More information about the Snort-users mailing list