[Snort-sigs] problem with snortsam patch

Al Lewis (allewi) allewi at ...3865...
Fri Apr 24 18:02:31 EDT 2015


Daniel,

                You are running a very outdated version of snort. I would suggest you download the current version (2.9.7.2) following the instructions on the site for installation.

Hope this helps.

Albert Lewis
QA Software Engineer
SOURCEfire, Inc. now part of Cisco
9780 Patuxent Woods Drive
Columbia, MD 21046
Phone: (office) 443.430.7112
Email: allewi at ...3865...

From: Daniel Lopez [mailto:danilogo1991 at ...2420...]
Sent: Friday, April 24, 2015 3:18 PM
To: Snort-sigs at lists.sourceforge.net
Subject: [Snort-sigs] problem with snortsam patch

Hi
I installed snort 2.9.5.3 on ubuntu 14.04 server and had it running good, then I tried to install snortsam by following this steps:

1- I download snortsam-patch (snortsam-2.9.5.3-1.diff.gz) from http://www.snortsam.net/files/snort-plugin/snortsam-2.9.5.3-1.diff.gz
2- I applied it ( "patch -p1 <../snortsam-2.9.2.2.diff ") and i got this:

patching file autojunk.sh
patching file etc/snort.conf
patching file src/Makefile.am
patching file src/fatal.h
patching file src/output-plugins/Makefile.am
patching file src/output-plugins/spo_alert_fwsam.c
patching file src/output-plugins/spo_alert_fwsam.h
patching file src/plugbase.c
patching file src/plugin_enum.h
patching file src/twofish.c
patching file src/twofish.h

I think it was ok.

3- Then i ran "./autojunk.sh" and I recieved this error:

./autojunk.sh: 4: ./autojunk.sh: aclocal: not found
./autojunk.sh: 6: ./autojunk.sh: automake: not found
./autojunk.sh: 8: ./autojunk.sh: autoheader: not found
./autojunk.sh: 10: ./autojunk.sh: autoconf: not found

i installed automake packet which (i think) contains the others 3 packets.

4- then i ran autojunk.sh
5- i compiled snort again and i get this error msg:
......
......
......
/usr/local/src/snort_src/snort-2.9.5.3/src/plugbase.c:1550: undefined reference to `AlertFWsamSetup'
collect2: error: ld returned 1 exit status
make[3]: *** [snort] Error 1
make[3]: Leaving directory `/usr/local/src/snort_src/snort-2.9.5.3/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/local/src/snort_src/snort-2.9.5.3/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/snort_src/snort-2.9.5.3'
make: *** [all] Error 2

Could you tell me what i'm doing wrong? what can i do to fix it?

Please could you answer me asap, i need it for my thesis.
Thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-sigs/attachments/20150424/69dc6b1a/attachment.html>


More information about the Snort-sigs mailing list