[Snort-sigs] SNORT version lifecycle

waldo kitty wkitty42 at ...3507...
Mon Oct 20 13:58:25 EDT 2014


On 10/20/2014 1:33 PM, Hanson.Webster at ...3973... wrote:
> OK I downloaded Snort 2.9.6.2 and daq 2.0.2 and installed them .  I can get
> pulled pork to update the rules now, however I can’t get Snort to start.  This
> is the error I get:
>
> Finished Loading all dynamic preprocessor libs from
> /usr/local/lib/snort_dynamicpreprocessor/
>
> ERROR: The dynamic detection library
> "/usr/local/lib/snort_dynamicrules/web-activex.so" version 1.0 compiled with
> dynamic engine library version 2.0 isn't compatible with the current dynamic
> engine library "/usr/local/lib/snort_dynamicengine/libsf_engine.so" version 2.1.

you need to clear all the old shared object files from that snort_dynamicrules 
directory... you might have to reinstall your new snort after that to ensure 
that any new files from the new snort are put back in place in there...

-- 
  NOTE: No off-list assistance is given without prior approval.
        Please *keep mailing list traffic on the list* unless
        private contact is specifically requested and granted.




More information about the Snort-sigs mailing list