<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 15 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri",sans-serif;}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:#0563C1;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:#954F72;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri",sans-serif;
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="#0563C1" vlink="#954F72">
<div class="WordSection1">
<p class="MsoNormal">Hello,<br>
<br>
I have set up Snort on pfSense and configured OpenAppID on the interfaces. However, I cannot get the application detection results properly. Sometimes the websites I browse are identified in the logs, sometimes the same websites are not. There are times the
 applications that I have not used are shown in the logs (the ones that I used in the past with the timestat showing the current time). On pfSense GUI , I have enabled/configured OpenAppID, and also on the pfSense console (FreeBSD) I have added the following
 lines in the snort.conf file (it was the same before I changed the snort.conf file):<o:p></o:p></p>
<p class="MsoNormal"><br>
preprocessor appid: app_stats_filename appstats-u2.log, \    <o:p></o:p></p>
<p class="MsoNormal">app_stats_period 60, \<o:p></o:p></p>
<p class="MsoNormal">app_detector_dir /usr/local/snort<br>
<br>
What changes should I make to get the proper and correct results in the log?<o:p></o:p></p>
<p class="MsoNormal"><br>
Another question is, since some websites have embedded micro-apps, like a number of websites have facebook or twitter on the main pages, in the logs they are also shown as appNames as detected. So, as a result in the logs, besides the webpage that has actually
 been visited there are also going to be some other embedded applications identified. Since, they are all presented as “appName=”  I cannot differentiate which app has actually been used, and which one is a micro-app embedded within the app used. Is there any
 way to differentiate these? <o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Thanks in advance.<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><span style="font-size:12.0pt">Best Regards,<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:12.0pt">Emil<b><span style="color:#4472C4"><o:p></o:p></span></b></span></p>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
</body>
</html>