<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 12 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
@font-face
        {font-family:Consolas;
        panose-1:2 11 6 9 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
p.MsoPlainText, li.MsoPlainText, div.MsoPlainText
        {mso-style-priority:99;
        mso-style-link:"Plain Text Char";
        margin:0in;
        margin-bottom:.0001pt;
        font-size:10.5pt;
        font-family:Consolas;}
span.PlainTextChar
        {mso-style-name:"Plain Text Char";
        mso-style-priority:99;
        mso-style-link:"Plain Text";
        font-family:Consolas;}
span.EmailStyle19
        {mso-style-type:personal;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
span.EmailStyle20
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal><span style='color:#1F497D'>Hi Abdel,<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D'>You need to change your compilation options and disable linux-smp-stats<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D'><o:p> </o:p></span></p><p class=MsoPlainText>--enable-dynamicplugin --enable-perfprofiling --enable-targetbased --enable-ipv6 --enable-ppm --enable-gre --enable-static-daq=no --enable-64bit-gcc=no <o:p></o:p></p><p class=MsoNormal><span style='color:#1F497D'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D'>Regards,<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D'>Guillaume DALEUX<o:p></o:p></span></p><p class=MsoNormal><span style='color:#1F497D'><o:p> </o:p></span></p><p class=MsoNormal><span style='color:#1F497D'><o:p> </o:p></span></p><div><div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in'><p class=MsoNormal><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>From:</span></b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'> Abdelmonaim Mokadem [mailto:abdelmonaim.mokadem@...1967...] <br><b>Sent:</b> Wednesday, May 16, 2012 2:11 PM<br><b>To:</b> snort-users@lists.sourceforge.net; snort-devel@lists.sourceforge.net<br><b>Subject:</b> [Snort-users] Perfmonitor Issue<o:p></o:p></span></p></div></div><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Hi all,<o:p></o:p></p><p class=MsoNormal>I have an issue using the perfmonitor preprocessor for snort inline  to provide the “Max performance snort stats” with the following parameters:<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>  preprocessor perfmonitor: time 300 pktcnt 5000 events max console<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Here are the options used to launch snort :<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>        -A none \<o:p></o:p></p><p class=MsoNormal>        --dynamic-engine-lib "${SNORT_ENG}" <o:p></o:p></p><p class=MsoNormal>        --dynamic-preprocessor-lib-dir "${SNORT_DYNPPDIR}"<o:p></o:p></p><p class=MsoNormal>        --dynamic-detection-lib-dir "${SNORT_DYNRULDIR}" <o:p></o:p></p><p class=MsoNormal>        --daq-dir "${DAQ_DIR}" <o:p></o:p></p><p class=MsoNormal>        -i "${INTERFACE}" <o:p></o:p></p><p class=MsoNormal>        -c "${SNORT_CONF}" <o:p></o:p></p><p class=MsoNormal>        --perfmon-file "${LOG_DIR}/snort.stats" <o:p></o:p></p><p class=MsoNormal>        -l "${LOG_DIR}" <o:p></o:p></p><p class=MsoNormal>        -Q<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Since I’m using the “max “ <span lang=EN-CA>and  “console” </span>parameters, my console should display the results, based on the following code:<o:p></o:p></p><p class=MsoPlainText>if(iFlags & MAX_PERF_STATS)<o:p></o:p></p><p class=MsoNormal>{<o:p></o:p></p><p class=MsoNormal>      .<o:p></o:p></p><p class=MsoNormal>      .<o:p></o:p></p><p class=MsoPlainText>  <span lang=FR>LogMessage("uSeconds/Pkt\n");<o:p></o:p></span></p><p class=MsoPlainText><span lang=FR>  LogMessage("----------------\n");<o:p></o:p></span></p><p class=MsoPlainText>  LogMessage("Snort:       %.3f\n",sfBaseStats->usecs_per_packet.usertime);<o:p></o:p></p><p class=MsoPlainText>  LogMessage("Sniffing:    %.3f\n",sfBaseStats->usecs_per_packet.systemtime);<o:p></o:p></p><p class=MsoPlainText>  LogMessage("Combined:    %.3f\n\n",sfBaseStats->usecs_per_packet.totaltime);<o:p></o:p></p><p class=MsoPlainText>  .<o:p></o:p></p><p class=MsoPlainText>  .<o:p></o:p></p><p class=MsoPlainText>}<o:p></o:p></p><p class=MsoNormal>But it doesn’t…<o:p></o:p></p><p class=MsoNormal>It doesn’t print me the Snort Max Performance at all..<o:p></o:p></p><p class=MsoNormal>The usec_per_packet structure is filled when “GetuSecondsPerPacket”  is called but it seems like we never enter in the “if” clause <o:p></o:p></p><p class=MsoNormal>and when I try to debug with gdb, I can see that “iFlag” is always equal to 0 for an unknown reason and since “MAX_PERF_STATS” is equal to 1, the “if” test fail.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>FYI, here are the options used to compile snort :<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoPlainText>--enable-dynamicplugin --enable-perfprofiling --enable-linux-smp-stats --enable-targetbased --enable-ipv6 --enable-ppm --enable-gre --enable-static-daq=no --enable-64bit-gcc=no <o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>If someone has an idea about the origin of the problem here…<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Regards,<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Abdelmonaim Mokadem.   <o:p></o:p></p><p class=MsoPlainText> <o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal> <o:p></o:p></p></div></body></html>