[Snort-devel] Fatal error while running Snort 2.6

Steven Sturges steve.sturges at ...402...
Fri Jun 23 08:55:09 EDT 2006


When you run the configure command, include --enable-dynamicplugin
as an option, and then rebuild snort.

Kamanhalli, Pavan S wrote:
> Hi,
>    I got an error while running snort 2.6. Previously I was using 2.4.4
> which ran perfectly without any errors.
> 
> ERROR: snort.conf(182) => Unknown rule type: dynamicpreprocessor
> Fatal Error, Quitting..
> 
> I looked into snort.conf but could not figure out anything. The line
> number 182 of snort.conf
> showed,
>       dynamicpreprocessor directory
> /usr/local/lib/snort_dynamicpreprocessor/ 
> 
>      I have downloaded the source and then compiled it on Tru64. When I
> tried to run,
> 
>       # ./snort -i tu0 -c snort.conf. I am getting the error. Kindly
> help me in fixing this.  
> 
> Thanks,
>  Pavan 




More information about the Snort-devel mailing list