[Snort-devel] incomplete libnet-detection for --enable-inline

Falko Wendt fwendt at ...2745...
Mon Apr 11 08:24:31 EDT 2005


Hi,

when compiling snort-2.3.2 i ran into a problem where configure would
not detect libnet-1.0.2a which i had installed to
/usr/local/libnet-1.0.2a even though i used --with-libnet-includes and
--with-libnet-libraries.
Looking at configure.in i saw that the checks for libnet which are used
when --enable-inline is given ignore --with-libnet-includes and only
search in /usr/include and /usr/local/include.
The code for --enable-flexresp on the other hand does extensive checks
for libnet and correctly detects it in non-standard locations.
Perhaps someone more knowledgeable could look at configure.in and
add the necessary checks to the code for --enable-inline.
A simple fix which worked for me follows:

===start============================================================================
--- configure.in        2005-03-10 22:35:43.000000000 +0100
+++ ../modified-snort-2.3.2/configure.in        2005-04-07
01:21:33.000000000 +0200
@@ -687,7 +687,11 @@

LIBNET_INC_DIR=""
AC_MSG_CHECKING("for libnet.h version 1.0.x")
-        libnet_dir="/usr/include /usr/local/include"
+        if test -n "$with_libnet_includes" -a "$with_libnet_includes" 
!= "no"; then
+               libnet_dir="${with_libnet_includes}"
+        else
+               libnet_dir="/usr/include /usr/local/include"
+        fi
for i in $libnet_dir; do
     if test -r $i/libnet.h; then
         LIBNET_INC_DIR=$i
===end==============================================================================

Ciao, Falko




More information about the Snort-devel mailing list