[Snort-devel] Snort upgrade from 2.0.2 to 2.1

Kevin Mcvey kmcvey at ...2363...
Mon Feb 2 11:26:16 EST 2004


I'm running Radhat 9, mysql, snort 2.0.2, apache, php and ACID.
Everything was running great until I tried to upgrade to version 2.1.
When I ran the following command:
./configure --with-mysql=/usr/local/mysql
 
I received an error that libpcre could not be found.  So I downloaded
pcre 4.3 from www.pcre.org <http://www.pcre.org/>  and installed it by
performing the following:
tar -xvzf pcre-4.3.tar.gz
cd pcre-4.3
./configure --prefix=/usr/local --enable-utf8
make 
make install
 
I ran the config command again to configure snort:
./configure --with-mysql=/usr/local/mysql
This time I didn't receive the pcre error so I continued to run make and
make install.  After installation was complete I copied all rule and
config files to the /etc/snort directory and made sure the
/etc/snort/snort.conf file was modified for my network.   I rebooted the
server and logged in to ACID and I'm not receiving any alerts.    
 
If I run /usr/local/bin/snort -V I receive the following output:
-*> Snort! <*-
Version 2.0.2 (Build 92)
By Martin Roesch (roesch at ...402..., www.snort.org
<http://www.snort.org/> )
For some reason I doesn't seem like snort updated.  
 
When I run /etc/init.d/snort start
Starting Intrusion Database System: SNORT
./snort: line 1: pidof: command not found
 
When I run /etc/init.d/snort stop
Stoping Intrusion Database System: SNORT
./snort: line 1: pidof: command not found
SNORT is  not running!
 
If I run /usr/local/bin/snort -v I can see packets fling by the screen
so this tells me snort is running. 
 
I'm fairly new to Linux and Snort any help would be greatly appreciated!
My IDS has been down for a week now. :-(
 
 


CBHNP DISCLAIMER NOTICE:
This document may contain confidential or proprietary information.  It is a violation of federal regulations for anyone other than the intended recipient to view such contents.  If you have received this email in error, please inform the sender immediately by email reply and delete the original.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.snort.org/pipermail/snort-devel/attachments/20040202/41839563/attachment.html>


More information about the Snort-devel mailing list