[Snort-devel] Re: snort dies on linux/sparc64 when using preprocessor stream4_reassemble

Jason Wever weeve at ...2185...
Fri Sep 26 04:29:02 EDT 2003


On Wed, 17 Sep 2003 18:21:00 -0400
Martin Roesch <roesch at ...402...> wrote:

> Well, it's obviously a memory alignment issue, we get these a lot in 
> the stream and frag reassemblers.  Have you tried running in gdb to see 
> what line the error is occurring on?

Sorry for the lack of response, been having mail issues.

Using gdb, I'm seeing the following;

-*> Snort! <*-
Version 2.0.1 (Build 88)
By Martin Roesch (roesch at ...402..., www.snort.org)
ERROR: log_tcpdump TcpdumpInitLogFile(): Permission denied
Fatal Error, Quitting..
(no debugging symbols found)...
Program exited with code 01.

The log dir I'm using, /var/log/snort, has perms for the snort user, which
I'm running snort with.  I've tried applying the setuid bit to snort
(which is currently owned by root) but this had no effect either.

-- 
Jason Wever
Gentoo/Sparc Team Co-Lead
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <https://lists.snort.org/pipermail/snort-devel/attachments/20030926/f543279b/attachment.sig>


More information about the Snort-devel mailing list