[Snort-devel] False Alarm - still not solved

Erek Adams erek at ...835...
Wed May 21 08:04:08 EDT 2003


On Wed, 21 May 2003, Holger Marzen wrote:

> OK, I got it.
> No configure.in and Makefile.in files, so I took snort-2.0.0 and
> extracted the snapshot archive over that directory. ./configure works.
> But make filed "I need automake 1.6".

[...snip...]

Do it the easy way.  Grab the CVS tarball, then unpack it.  Change into
the snort directory and then ./autojunk.sh.  It will create the missing
configure for you.  For that to work you'll need automake, autoheader and
autoconf.  As for versions, on my OpenBSD box I'm working just fine with
autoconf-2.13, autoconf-2.52 and automake-1.4-p6.  About needing Perl,
I've got no idea why that popped up, as it's not needed.  Have a look
below...

Here's where I just got the newest tarball, checked for configure, used
autojunk.sh to generate it, made sure it's there, and then checked for the
word 'perl' in configure.

  [erek at ...1994...]/usr/local/build/cvs/snort>ls -al configure
  ls: configure: No such file or directory
  [erek at ...1994...]/usr/local/build/cvs/snort>./autojunk.sh
  [erek at ...1994...]/usr/local/build/cvs/snort>ls -al configure
  -rwxr-xr-x  1 erek  wheel  121993 May 21 10:57 configure
  [erek at ...1994...]/usr/local/build/cvs/snort>grep -i perl configure
  # fails to work properly with custom macroses.
  [erek at ...1994...]/usr/local/build/cvs/snort>

Cheers!

-----
Erek Adams

   "When things get weird, the weird turn pro."   H.S. Thompson




More information about the Snort-devel mailing list