[Snort-devel] Re: Snort 2.0 rc1 available

Jeff Nathan jeff at ...835...
Wed Mar 26 17:06:09 EST 2003


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Dimitry,

Thank you for notifying us so quickly, this project is lucky to have a 
large base of users and developers.

It appears as though the Linux distributions are at it again, doing their 
little bit to make all our collective lives easier while happily ignoring 
standards - though I suppose in this case, it's GNU and not any Linux 
distribution in particular.

The -m switch in the wc utility is part of POSIX.2 (IEEE Std1003.-1992) and 
after running a number of tests I believed that -m was supported 
universally by wc.  I currently have access to two Linux boxes, both of 
which I use for development and testing (each running a different Linux 
distribution).  When I tested the changes to configure they worked properly 
and thus Chris committed them.

When RC2 is available, I'm certain this will be corrected.

As a side note, you've got to admit, it's a bit difficult to keep up with 
the whimsical choices made as to which userland package is going to be used 
by the  various Linux distributions.  Whose version of traceroute are they 
using this week, netkit or is it NANOG? :)

The warnings about libnet-config being broken are my little effort to 
convince operating system groups and/or package maintainers to be a little 
bit less .... lazy.  Yes, that's the word I'm looking for.

Take care and thanks for using Snort.

- -Jeff

- --On Thursday, March 27, 2003 0:49 +0100 Dimitry Andric <dim at ...349...> 
wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> On 2003-03-26 at 22:48:01 Martin Roesch wrote:
>
> MR> The Snort 2.0 release candidate 1 is available for your testing.
>
> Alas, configure --enable-flexresp errors out:
>
> ==========
> checking for pcap_datalink in -lpcap... yes
> wc: invalid option -- m
> Try `wc --help' for more information.
> ./configure: test: =: unary operator expected
> wc: invalid option -- m
> Try `wc --help' for more information.
> ./configure: test: =: unary operator expected
> checking for libnet.h... yes
> checking for libnet version 1.0.2a... no
>
>
> **********************************************
>   ERROR: unable to find libnet 1.0.2a (libnet.h)
>   checked in the following places
> **********************************************
> ==========
>
> This is due to the '-m' option used with wc in some of the tests,
> which is not supported by all versions of wc. For example, I'm using
> Debian -stable here, which comes with wc from GNU textutils 2.0.
>
> For me, replacing -m with -c solved the issue, although this may not
> be what the author of configure.in intended. A patch for that is
> attached. (A similar patch works for the current CVS version.) Snort
> then configures and builds without a hitch.
>
> Also, I then got a warning about libnet-config supposedly being
> broken:
>
> ==========
> checking for pcap_datalink in -lpcap... yes
> configure: warning: libnet-config --cflags is broken on your system.  If
> you configure: warning: are using a precompiled package please notify the
> configure: warning: maintainer.
> checking for libnet.h... yes
> ==========
>
> It seems that on Debian stable, which has libnet 1.0.2a, the cflags
> are always empty. Any idea why this might be a problem? It doesn't
> really seem to matter for the building process. If it actually is,
> I'll be happy to file a bug report with Debian. :)
>
> Cheers,
> - --
> Dimitry Andric <dim at ...349...>
> PGP Key: http://www.xs4all.nl/~dim/dim.asc
> Fingerprint: 7AB462D2CE35FC6D42394FCDB05EA30A2E2096A3
> Lbh whfg ivbyngrq gur QZPN naq jvyy or cebfrphgrq
>
> -----BEGIN PGP SIGNATURE-----
> Version: 6.5.8ckt http://www.ipgpp.com/
> Comment: http://duncan.gn.apc.org/stoa_cover.htm
>
> iQA/AwUBPoIum7BeowouIJajEQJKrQCePRrxN+vkzv7eUHeDMzbwgyJG1QsAoJEV
> Io57OxqMf9ZnOHCLswjnmGlb
> =iFk1
> -----END PGP SIGNATURE-----



- --
http://cerberus.sourcefire.com/~jeff       (gpg key available)
"Great spirits have always encountered violent opposition from mediocre
minds."
- - Albert Einstein
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (Darwin)

iD8DBQE+gk5KEqr8+Gkj0/0RAj/aAJ9CZpk6ykLS6GFIZ26cV/V//JS8ogCgroUK
WZhKx2rHuR0iOAJdRiXy5e0=
=U+f4
-----END PGP SIGNATURE-----





More information about the Snort-devel mailing list