[Snort-devel] New Snort rpmbuild capability

Sheppard Martin Contr AFRL/IFGB Martin.Sheppard at ...2281...
Thu Dec 11 06:00:02 EST 2003


Hello all,

This morning I built Snort 2.0.5 on a machie running Linux 8 using the
command "rpmbuild -ta <name of snort tarred gzipped filename>".  The build
went fine.  I added my site snort.conf and rules files and tryed to start
snort.  Snort did not start.  Upon checking the log I found that the default
rpmbuild does not make an rpm  capable of logging to mysql.  I then did a
little searching and found how to build the package logging to mysql.  The
command "rpmbuild --with mysql -ta <name of snort tarred gzipped filename>"
worked just fine apparently (at least the snort rpm was built in the
RPMS/i386 directory.  My problem is now that the resulting rpm will not
install.  The error is as follows:

[afed at ...2282... i386]$ sudo rpm -ivh snort-2.0.5-1.i386.rpm 
error: Failed dependencies:
        snort = 2.0.5 is needed by snort-mysql-2.0.5-1
[afed at ...2282... i386]$ 

Ummm what gives?  This is snort that I am installing!   Anyone else running
into this behavior, or am I doing something wrong?

Havve a GREAT day all!

later,
marty.




More information about the Snort-devel mailing list