[Snort-devel] [ snort-Bugs-532166 ] broken configure script for flexresp

noreply at ...12... noreply at ...12...
Sat Mar 23 18:58:34 EST 2002


Bugs item #532166, was opened at 2002-03-19 21:59
You can respond by visiting: 
http://sourceforge.net/tracker/?func=detail&atid=103357&aid=532166&group_id=3357

Category: None
Group: None
>Status: Pending
>Resolution: Remind
>Priority: 3
Submitted By: Jason Haar (jhaar)
Assigned to: Nobody/Anonymous (nobody)
Summary: broken configure script for flexresp

Initial Comment:
 I reported this back in December, 
and it's still present in 1.8.4. 
 
Under RH 7.1 at least, configure 
correctly detects  u_int8_t and co 
UNLESS you "configure 
--with-flexresp". At that stage 
configure reports that it cannot find 
those functions, and the compile 
fails. The problem is the flexresp 
shell code calls libnet --config and 
pushes that into CFLAGS. One of the 
defines is -D__BSD_SOURCE. With this 
defined, u_int8_t/etc don't get 
defined. 
 
Originally just moving the flexresp 
code in configure underneath the 
u_int8_h/etc stuff fixed the 
problem... 
 
This is RH7.1 with libnet-1.02a, 
gcc-2.96 
 

----------------------------------------------------------------------

Comment By: Chris Green (chrisgreen)
Date: 2002-03-21 23:10

Message:
Logged In: YES 
user_id=429629

work around:

aclocal
automake

I think it was an issue with the FreeBSD release environment
and we resorted to that quickly after I broke the scripts
under OS X.



----------------------------------------------------------------------

You can respond by visiting: 
http://sourceforge.net/tracker/?func=detail&atid=103357&aid=532166&group_id=3357




More information about the Snort-devel mailing list