[Snort-devel] barynard beta8 config problem

Jeff Nathan jeff at ...835...
Mon Jun 24 17:13:12 EDT 2002


Michael Scheidell wrote:
> 
> Hey these folks
> 
> Downloaded latest barynard, beta8.
> never had any problem with beta4,5,6 or 7 in the config.
> 
> put in into 'clean' directory, did ../configure --enable-mysql
> 
> got this:
> 
> checking for /usr/local/include/mysql/mysql.h... yes
> test: /usr/local/lib/mysql/libmysqlclient.so.10: unexpected operator
> checking for mysql_connect in -lmysqlclient... no
> 
> **********************************************
>   ERROR: unable to find mysqlclient library
>   checked in the following places
> **********************************************

[...]

Oops,

We were experimenting with handling other forms of libmysqlclient other
than .so and symlinks to libmysqlclient where the shared object has
version extensions.  It looks like the last patch didn't work as
planned, especially of libmysqlclient.* expands into several files.

The attached patch should fix the problem.

-Jeff

-- 
http://jeff.wwti.com            (pgp key available)
"Common sense is the collection of prejudices acquired by age eighteen."
- Albert Einstein
-------------- next part --------------
A non-text attachment was scrubbed...
Name: barnyard_beta8_configure_in.patch.gz
Type: application/x-gzip
Size: 411 bytes
Desc: not available
URL: <https://lists.snort.org/pipermail/snort-devel/attachments/20020624/4b8d7cc6/attachment.bin>


More information about the Snort-devel mailing list