[Snort-devel] Feature request - Minimum snort version option?

Mark Vevers mark at ...1209...
Mon Jun 10 09:28:05 EDT 2002


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

I was wondering if it might be possible to add something to the Snort wish 
list - a new option called 'minimum snort version' which gives the min 
version of the code required to work with the rule.  This would be extremely 
useful for large multi-sensor environments since it would allow a controlled 
update approach when a new rules or a new version of snort are/is released.

It would also allow rule management software not to send known incompatible 
rules to sensors hence causing them to fail ....   I am adding code to RMAN 
to make this less of an issue, but this would make snort version/rule version 
handling an awful lot easier and neater.

Cheers
Mark
- -- 
Mark Vevers.    mark at ...1121... / mvevers at ...1186...
Internet Backbone Engineering Team
Internet for Learning, Research Machines Plc
Tel: +44 1235 823380,   Fax: +44 1235 823424
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org

iD8DBQE9BNNtWLU9HLCPPKMRAtz4AKCB3sEyELi46IuLgcOUHCnHdPzWtgCfXf8W
wdw07zYc19W6Ydl+Ec1GKSE=
=embA
-----END PGP SIGNATURE-----





More information about the Snort-devel mailing list