[Snort-devel] Patch to support Oracle 9 with configure

Kreimendahl, Chad J Chad.Kreimendahl at ...1167...
Thu Apr 11 13:31:34 EDT 2002


I had submitted a bug earlier relating to the fact that snort's
configuration utility only looks for Oracle 8 libs. ... Those of us with
Oracle 9 had to modify the following two files and change an 8 to a 9.
I've included diffs of my code compared to the current CVS code....  I
tested these changes and it compiled wonderfully...

Thanks,
 -CJK
-------------------------------------------------------------------


Index: configure
===================================================================
RCS file: /cvsroot/snort/snort/configure,v
retrieving revision 1.91
diff -r1.91 configure
5032c5032,5038
<     LIBS="${LIBS} -lclntsh -lwtc8"
---
>     ORACLE_LIBS="-lclntsh"
>     if test -r $ORACLE_LIB_DIR/libwtc9.so; then
>       ORACLE_LIBS="${ORACLE_LIBS} -lwtc9"
>     elif test -r $ORACLE_LIB_DIR/libwtc8.so; then
>       ORACLE_LIBS="${ORACLE_LIBS} -lwtc8"
>     fi
>     LIBS="${LIBS} ${ORACLE_LIBS}"





Index: configure.in
===================================================================
RCS file: /cvsroot/snort/snort/configure.in,v
retrieving revision 1.85
diff -r1.85 configure.in
525c525,531
<     LIBS="${LIBS} -lclntsh -lwtc8"
---
>     ORACLE_LIBS="-lclntsh"
>     if test -r $ORACLE_LIB_DIR/libwtc9.so; then
>       ORACLE_LIBS="${ORACLE_LIBS} -lwtc9"
>     elif test -r $ORACLE_LIB_DIR/libwtc8.so; then
>       ORACLE_LIBS="${ORACLE_LIBS} -lwtc8"
>     fi
>     LIBS="${LIBS} ${ORACLE_LIBS}"




More information about the Snort-devel mailing list