[Snort-devel] Problems building snort 1.7 on OpenBSD

Martin Roesch roesch at ...48...
Wed Jan 17 16:46:47 EST 2001


This is a known issue, we're working on a fix.  A quick fix just to get
running would be to make a change to the GetIfrMTU() function in snort.c
and make sure it always returns 1500.  An easy way to do this would be
to make the first line in the function below the variable declarations
read "return 1500;".

    -Marty

Keith McDuffee wrote:
> 
> I thought I had this fixed, but apparently not.
> 
> The last release before 1.7 worked fine. Now when I start snort I get the
> following error:
> 
> snort -i fxp0 -d -h 192.168.1.0/24 -s -l /var/logs/snort-c /etc/snort.rules
> 
> --== Initializing Snort ==--
> Initializing Network Interface fxp0
> ioctl(SIOCGIFMTU): Invalid argument
> ERROR: Can not get MTU of an interface fxp0!
> ----
> 
> fxp0 is the main interface name and is what I've used in the past. Any idea
> what's changed?
> 
> System Architecture: i386 PC
> OS: OpenBSD 2.6
> Rules: Latest file dated 1/8/2001 on snort.org
> Command line switches: (See above)  Also tried without the -i option
> Error messages: (See above)
> 
> Thanks,
> Keith
> 
> _______________________________________________
> Snort-devel mailing list
> Snort-devel at lists.sourceforge.net
> http://lists.sourceforge.net/lists/listinfo/snort-devel

--
Martin Roesch
roesch at ...48...
http://www.snort.org




More information about the Snort-devel mailing list