[Snort-devel] Problems with libnet 1.0.2

Jason Larsen larsjaso at ...282...
Mon Apr 23 20:55:17 EDT 2001


I haven't tried, but usually you get that error when you don't put a 
`libnet-config --libs --cflags` on the end of the compile line.

Jason Larsen
larsjaso at ...283...

----- Original Message ----- 
From: "Deven Phillips" <dphillips at ...392...>
To: <snort-devel at lists.sourceforge.net>
Sent: Sunday, April 22, 2001 8:13 PM
Subject: [Snort-devel] Problems with libnet 1.0.2


> All,
> 
> I have downloaded the latest version of snort, and I tried to compile
> it on Mandrake 8.0. The configure script runs, and the make process
> starts out fine. When make goes to compile sp_response.c, I get an error
> about not having defined if the system is big/little endian. I inserted
> a line in the source file "#define LIBNET_LIL_ENDIAN" and tried to
> compile again. I then recieved more erros that look to be that snort's
> current source is not compatible with this version of libnet. Can anyone
> confirm/deny this? Does anyone have a fix?
> 
> Deven Phillips, CISSP
> Information Security Officer
> Viata Online, Inc.
> -- 
> -----BEGIN GEEK CODE BLOCK-----
> Version: 3.12
> GCS d+ s: a- C++++ UL++++ P- L+++ E- W+ N++ o-- K w---
> O M-- V- PS+ PE Y+ PGP++ 5+++ X+ R tv+ b+ DI+ D-
> G e* h--- r++ y+++
> ------END GEEK CODE BLOCK------
> 
> _______________________________________________
> Snort-devel mailing list
> Snort-devel at lists.sourceforge.net
> http://lists.sourceforge.net/lists/listinfo/snort-devel
> 






More information about the Snort-devel mailing list